"About" section text cut off by widget area

Mauer Themes Support Storyteller "About" section text cut off by widget area

Tagged: , ,

This topic contains 16 replies, has 2 voices, and was last updated by  Paul 4 months ago.

Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
    Posts
  • #779

    lushinn
    Participant

    Hello again, the About page on my main menu – the text is being cut off by the widget area and is not scrolling.

    #786

    Paul
    Keymaster

    Hello Lushinn,

    Can you please post a link to your website, so I could dig into the issue?

    Are you still using that custom CSS code you were trying to modify the footer with?

    Paul

    #792

    lushinn
    Participant

    http://www.why-detroit.com/about-me/

    I had tried but I don’t actually think any of the CSS codes I’ve tried are working.

    Thanks (again!) Paul

    #794

    lushinn
    Participant

    Hadn’t realized, 3 of 5pgs in my Main Menu (except Home and Contact) are doing the same thing.

    Gallery


    http://www.why-detroit.com/sample-page__trashed/blog/ (<<not sure why the Blog pg url is this)

    #797

    Paul
    Keymaster

    Lushinn,

    Please remove the CSS code you inserted, and see if the problem persists.

    Thank you.

    #830

    lushinn
    Participant

    Hi Paul, I removed the CSS code for the footer and it’s still happening. The only code I’m using is the one you provided for the photo overlay. Other ideas?

    Thanks!

    #838

    Paul
    Keymaster

    Hi Lushinn,

    If you take a look at the original ‘not found’ page (http://storyteller.mauer.co/aDAdddsa) and the ‘not found’ page on your website (http://www.why-detroit.com/about-me/), you can see they behave differently. The original one does not have any overlapping issues.

    I can also see that the code on your page is different from the code found in the original theme: Here is an example of a code difference.

    So basically what I’m saying is: something’s modifying that code (probably some JS script). I would suggest to try turning off the plugins you’ve installed one by one — and see if it’s some of them that’s causing the issue.

    Paul

    #853

    lushinn
    Participant

    Hi Paul, it was the Jet Pack plugin causing the issue. Thanks for your advise! I have two more questions: how can I use the galleries function? (as in the demo) I thought it would be in the customization. And is there CSS that would prevent hyphens in all text — including titles. I’ve tried a few that aren’t working on either.

    Thanks!

    #854

    lushinn
    Participant

    The subscribe Via Email widget is no longer available ? It disappeared after deactivating the Jet Pack plugin and now I can’t find a way to restore in the widget area.

    #856

    Paul
    Keymaster

    Hi Lushinn,

    Yes, it’s Jetpack that provides the email subscription in the demo. And also it powers the tags that provide a page picture to Facebook when you post a link there. So Jetpack is pretty useful.

    Actually, the demo has Jetpack running and at the same time does not have a problem with overlapping footer.

    If you want, you can send me your WP Admin credentials over to pavel@mauer.co (let me know here after you do) and I can take a look and try to see what is causing this behavior in your particular setup.

    Paul

    #858

    lushinn
    Participant

    Just sent you an email.

    #864

    Paul
    Keymaster

    Hello Lindsay,

    As of now, I don’t see the footer overlapping the content area with Jetpack activated.

    And also I see you use caching.

    So what I assume has happened is the following:
    It’s whether one of the plugins caused the error or a code customization. Then the site got cached. Then you started deactivating the plugins to track down the issue. However you did not reset the cache, and the changes were not taking effect immediately. And most probably it was not Jetpack that was causing the problem (it’s not creating issues in the demo). It was just that the moment you turned off Jetpack, your cache got updated. And you thought that was the reason. However that was a coincidence.

    So just remember that when you are doing something with the code, your site continues to serve the old code (from local cache or CDN) for some time unless you update the cache manually. It is a good idea to turn off caching completely before making code modifications, and turn caching back on and make sure to reset (purge) it once you’re finished.

    As of now I see no issues with the footer overlapping the content area. If you experience them again, make sure there’s no caching going on before troubleshooting.

    As for hyphenation, it is performed by the browser in which the site is viewed. Moreover, different browsers hyphenate differently. And I’m totally with you on that — sometimes the hyphenation that they perform does not look very good. The quality of the hyphenation can also be affected by the language that the site uses. You can turn off hyphenation site-wide by adding the following CSS code. BTW, I would advise to keep all your custom CSS in one place (now you have some in ‘Appearance’ > ‘Edit CSS’, and some in ‘Appearance’ > ‘Custom CSS’). The code is:

    body {
    	-webkit-hyphens: none;
    	-moz-hyphens: none;
    	hyphens: none;
    }

    Again, to see this code work, be sure that you are not being served a cached version of your website.

    The galleries. Yes, as you’ve written in your email they are controlled by the native WP Gallery interface. You can add them to whether pages or posts. And then you can place those on the menu.

    The ACF PRO plugin. This plugin handles theme settings, and it’s really important for the theme. You can not update the plugin on your own because the ACF PRO license does not allow that if you got a copy of the plugin as part of a theme (you’d need to directly buy a license for ACF PRO to be able to update it).

    I update the version of ACF PRO bundled with the theme with every theme update — which usually happens every several months.

    The changes in the latest version of the ACF PRO are really minor and don’t affect the performance of the theme in any way. So if you ask me, it actually does not seem to be worth the hassle.

    However, if you still want to have the latest version of ACF Pro in your theme, please drop me an email at pavel@mauer.co and I’ll send you a zip to install.

    Best,
    Paul

    #1002

    lushinn
    Participant

    Hi Paul,

    It’s cutting off at the bottom margin again all off a sudden — all pages. When I deactivate Jetpack it’s good. When I reactivate it cuts off. I’ve gone through all other plug-ins and it changes every time I activate/deactivate Jetpack. What I don’t understand is that it was fine until my last two posts.

    Can you please look into this and let me know what you think. It’s also doing it on mobile.

    Thanks so much!

    #1008

    Paul
    Keymaster

    Hello Lindsay,

    Please email me your WP Admin credentials and I’ll take a look at it.
    Once you email them, please ping me here.

    Paul

    #1024

    lushinn
    Participant

    Just sent them. Thanks Paul!

    #1027

    Paul
    Keymaster

    Thank you. Please also send your wordpress.com credentials (I need them to experiment with turning Jetpack on and off). Also, are you using any external caching (like CloudFlare)?

    #1084

    Paul
    Keymaster

    Lindsay,

    Yes, I can see that turning JetPack on/off triggers the issue. However the demo is also using JetPack, and there are no errors.

    So we need to look at what is different between the demo and your website. And this is caching. What I suggest you do is completely remove the W3 Total cache plugin and all the stuff that it has created (follow this guide, starting at “How To Uninstall W3 Total Cache WordPress Plugin”: https://wp-rocket.me/faq/w3-total-cache-fixes/). Or you can just export your current content, and setup the site from scratch without any caching.

    I’ve turned off JetPack for the time being.

    Paul

Viewing 17 posts - 1 through 17 (of 17 total)

You must be logged in to reply to this topic.