Font – HK Grotesk vs Polish language

Mauer Themes Support Stills Font – HK Grotesk vs Polish language

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #3651
    gosia
    Participant

    Hi,
    I use default font HK Grotesk in Polish language version of website. HK Grotesk has Polish language diactric marks designed but they don’t appear properly.
    Letters shoud look like that:
    https://www.dropbox.com/s/p2r80ix5ypqj30p/hkgrotesk_example.jpg?dl=0

    Unfortunately they look like that:
    https://www.dropbox.com/s/yj4zom0f2q5ejxh/hkgrotesk_example2.jpg?dl=0

    I have already tried to add latin,latin-ext in Google Fonts extra subsets (Theme options/Fonts) but it still doesn’t work properly.

    Could you please help me to fix this problem?
    Thanks in advance!
    Gosia

    • This topic was modified 2 years, 1 month ago by gosia.
    • This topic was modified 2 years, 1 month ago by gosia.
    #3655
    gosia
    Participant

    Hi again,
    when can I expect the answer?

    Also I have few more questions:
    1. How can I change text in “All” category in portfolio for Polish translation?
    2. How can I change text in “Read more” blog button?
    3. How can I change text in “Related posts”?

    Best from Warsaw/Poland.
    Gosia

    • This reply was modified 2 years, 1 month ago by gosia.
    #3657
    gosia
    Participant

    Hallo?

    #3658
    Paul
    Keymaster

    Hello Gosia,

    Speaking of translating static phrases like “read more”, or “older posts”, or “all”,

    This theme is translation-ready in a regular WordPress fashion. That means it comes with a language file which has all the default texts.

    That said, I believe the easiest way of translating a theme is by using the Loco Translate plugin.

    After you install and activate it, in your Admin Panel please go to ‘Loco Translate’ > ‘Themes’ > ‘Mauer Essentialist’ and click ‘New Language’.

    Select your language (in this example it’s ‘Portuguese’, please choose Swedish for your website). And click ‘Start translating’:

    You will see a list of all the strings ready to be translated. Here is how it looks:

    When you’re done translating, click ‘Save’ and ‘Sync’.

    Now if you have your WordPress language set to (in this example) Portuguese*, then your website will display the translated strings.

    _______
    
* — ‘Settings’ > ‘General’ > ‘Site language’ (at the bottom).

    As for the Polish characters in HK Grotesk, let me try a few things and get back to you with a solution.

    Regards,
    Paul

    #3659
    gosia
    Participant

    Hi,
    thank you for your answer.

    “
*” from the end of your post-> I don’t know what it is. Could you pls specify?

    I am looking forward to hearing from you soon.

    Best,
    Gosia

    • This reply was modified 2 years, 1 month ago by gosia.
    • This reply was modified 2 years, 1 month ago by gosia.
    #3663
    Paul
    Keymaster

    Hi Gosia,

    In the “*” section, I was actually pointing out the location of the language setting in the WP Admin. Please see this screenshot.

    Regards,
    Paul

    #3664
    Paul
    Keymaster

    I have found a solution to displaying Polish characters in HK Grotesk. I will post it by tomorrow morning.

    #3667
    Paul
    Keymaster

    Gosia,

    I have just emailed you an archive link to malgorzata.sinkiewicz@gmail.com. Please unpack that archive and replace the HKGrotesk folder in mauer-stills/fonts with the contents of the archive.

    After that, Polish characters will correctly display in HK Grotesk, like this (see the first paragraph).

    Regards,
    Paul

    #3670
    gosia
    Participant

    Hi,
    I did what you wrote. As a result diactric marks are ok but the font has changed for the different one (not HK Grotest).
    Regarding translating – it worked but not for “Other works:” displayed in portfolio in the bottom.

    Could you please help me?
    Gosia

    • This reply was modified 2 years ago by gosia.
    • This reply was modified 2 years ago by gosia.
    #3673
    gosia
    Participant
    #3674
    Paul
    Keymaster

    Hi Gosia,

    As for the diacritic marks, can you please send your WP Admin credentials to pavel [at] mauer.co, so that I could take care of this?

    Regards,
    Paul

    #3675
    gosia
    Participant

    Sent via e-mail.

    #3676
    gosia
    Participant

    Regarding “Other works:” – I’ve just found where to change it:)

    #3677
    Paul
    Keymaster

    Hello Gosia,

    I have fixed the font on your website. You might need to clear the browser cache to see the change.

    What I did is I’ve put the HKGrotesk folder from the archive I sent you into the fonts folder. It used to be in fonts/HKGrotesk/HKGrotesk, not in fonts/HKGrotesk.

    Regards,
    Paul

    #3678
    gosia
    Participant

    Great, thank you:)

    #3866
    Paul
    Keymaster

    You are welcome, Gosia!

    Best,
    Paul

Viewing 16 posts - 1 through 16 (of 16 total)
  • You must be logged in to reply to this topic.