Password Protect

Mauer Themes Support Bild Password Protect

This topic contains 9 replies, has 2 voices, and was last updated by  Paul 1 week, 2 days ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #2303

    DavidAngel
    Participant

    Hi.

    The theme is fabulous. Thanks for making a simple but stylish theme.
    I am wanting to make a gallery accessible with a password, but when I choose the ‘password protected’ button and enter a password the gallery is still visible (live) without putting in the password.

    The ‘public’ selection button has a blue halo around it.

    Many thanks
    David Angel

    • This topic was modified 2 months, 2 weeks ago by  DavidAngel.
    #2306

    DavidAngel
    Participant

    ..also if it is not too detrimental to performance, how do I go about hiring a programmer/getting a quote to add autoplay (fading) on tablets and phone..?

    thanks again,

    David

    #2523

    Paul
    Keymaster

    Hi David,

    To be able to password-protect galleries (the Gallery post type), please replace the content-gallery_content.php file in the theme folder with the one that I’ve just emailed to you (to the address with which you are registered on this forum).

    When testing the password-protected galleries make sure you are logged off.

    Sorry for the late reply. Just got back from a vacation. Won’t have another one for a long time. So I will respond faster.

    Regards,
    Paul

    #2525

    Paul
    Keymaster

    David,

    To have the slides autoplay on touch devices, please do the following:

    In your Admin Panel go to ‘Appearance’ -> ‘Editor’, find the js/general.js file in the list on the right.

    In that file replace the following string:
    if (slider && slider.st.autoPlay.enabled && !isTouchDevice()) {slider.startAutoPlay();}

    with this one (the end result should look like this — screenshot):
    if (slider && slider.st.autoPlay.enabled) {slider.startAutoPlay();}

    Click the ‘Update file’ button.

    This will make the slides autoplay with the ‘slide’ effect (not the ‘fade’). It’s not possible to make autoplay fade while making swiping slide. It’s got to be one or the other. If you want the images to fade both on click and during autoplay, please let me know and I’ll provide an additional code modification.

    Regards,
    Paul

    ——
    A little disclaimer: It’s best to do such customizations in a child theme or a custom plugin, so they do not get overwritten during theme updates. However, of course, you can always re-introduce them after a theme update.

    #2533

    DavidAngel
    Participant

    Thanks Paul!

    It would be great to have the code for the fade version.
    I will also look up child themes. I get the way the parent/child themes interact but sadly my technical ability doesn’t stretch anywhere near that far.
    If there is a custom plugin that you would recommend that doesn’t interfere with the fabulousness (speed and functionality) of the existing version, then could you recommend one..

    thanks again,
    David

    #2553

    Paul
    Keymaster

    Hello David,

    To switch to the fade effect when autoplaying/clicking slides on touch devices please do the following:

    In your Admin Panel go to ‘Appearance’ -> ‘Editor’, find the js/general.js file.

    Replace this line (should be around line 138 of the file):
    if (isTouchDevice()) {trType = 'move';}

    With this:
    // if (isTouchDevice()) {trType = 'move';}

    And speaking of the plugin you asked about, I’m not sure I understand what you want a plugin for. I mean what should the functionality of this plugin be?

    Also, I would say that the customizations that I provided here aren’t worth the hassle of figuring out how to create WP child themes if you aren’t a technical person. After you update the theme next time (updates don’t happen often), you can just go back to this post and make the changes again. That would be much faster and more efficient than spending the time to learn to create child themes.

    Regards,
    Paul

    #2558

    DavidAngel
    Participant

    Thanks Paul,

    No problem, I think I misunderstood the last answer re: plug in. As you have suggested I will look out for updates and make the change manually when necessary.

    Ta!
    David

    #2559

    DavidAngel
    Participant

    Hi Paul,

    I think I have a glitch. It is only apparent on my computer in both Safari and Firefox. It is not happening on my other website which is also using the Bild theme. It is also not happening on mobile devices.
    On the Front Page Gallery the instagram Logo (at the bottom of the page) and the short grey line next to to is too high and appearing over the bottom of the picture.. Likewise on the Dogs! section the Logo and the long grey line at the foot are again too high cutting into the line of pictures.

    website address is here:
    http://www.downwiththedogs.com

    there are some screenshots here:
    https://www.dropbox.com/sh/nuk4hcwj3skfjhi/AABkEXWFlqQuH2HDq751Kimia?dl=0

    Thanks
    David

    #2573

    DavidAngel
    Participant

    Hi Paul,
    Please disregard above problem with line in wrong place.
    It is only happening when I am logged into the site and editing the site, not when I am logged out, so nobody else will have a problem.

    many thanks,
    David

    #2807

    Paul
    Keymaster

    Hi David,

    Thanks for letting me know about this little issue. I’ll take care of it during the next update.

    Regards,
    Paul

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.