SEO – H1 Heading

Mauer Themes Support Stills SEO – H1 Heading

This topic contains 5 replies, has 2 voices, and was last updated by  chiara0000 1 week, 1 day ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #3609

    chiara0000
    Participant

    Hello,

    thanks for creating this beautiful theme. My website looks pretty much like the demo, with the portfolio as home page.
    This is my first website with WordPress. I am trying to improve my SEO and I have analyzed my website with some SEO analyzers (like seobility.net). One of the problems is that “There is no H1 heading specified” (of course on the home page there are no H1s).
    Is there something that can be done about it?

    Thanks!

    #3614

    chiara0000
    Participant

    Hello,

    I write again because more than 2 weeks had passed and I really need some support about this issue…
    Also, I would like to ask you some help regarding the java scripts files, that apparentely are too many on my website.

    I understood that support from the author is included with the purchase of the theme…
    I would really appreciate your help.

    Thanks and have a nice day

    Chiara
    wwww.chiarabellamoli.com

    #3631

    Paul
    Keymaster

    Hello Chiara,

    Here is how you can make this customization and transform the Welcome phrase on the front page (‘Sincere portrait…’ in the demo) to an h1:

    1. In your Admin Panel go to ‘Appearance’ > ‘Theme Editor’. On the right, in ‘Theme Files’ click ‘Portfolio Page Template’. Find this line (somewhere around line 17, depends on the theme version you are using):

    <div class="portfolio-welcome-phrase no-auto-hyphenation"><?php echo get_field('portfolio_welcome_phrase', 'option'); ?></div>

    and replace it with this:

    <h1 class="portfolio-welcome-phrase no-auto-hyphenation"><?php echo get_field('portfolio_welcome_phrase', 'option'); ?></h1>

    Click ‘Update file’. The end result should look like this: please see screenshot.

    2. Go to ‘Appearance’ > ‘Edit CSS’ in your Admin Panel. Paste the following code and click ‘Publish’:

    .portfolio-welcome-phrase {margin:0;}

    Please let me know if this has worked out for you.
    I am sorry for the late reply.

    Regards,
    Paul

    • This reply was modified 1 month ago by  Paul.
    #3640

    chiara0000
    Participant

    Hi Paul,

    thank you very much for your help. Yes it works!

    I also have another problem: apparently my website loads 6 java scripts files, and is in fact very slow… but I don’t know how to reduce them. Would you please have a look into it?

    Thank you again.

    Chiara

    #3642

    Paul
    Keymaster

    Chiara,

    From what I can see chiarabellamoli.com is working pretty fast, Pingdom is giving it a performance grade of 90/100.

    Actually, the mere fact that you have 6 JavaScript files loading is not an indication of anything. All of them weigh less than a single image. And 6 is not much. For instance, this very page is loading 30+ JavaScript files.

    If you want to increase the performance of your website, you can use a solution like Autoptimize. Another thing to do would be to upgrade your hosting.

    Regards,
    Paul

    • This reply was modified 2 weeks, 1 day ago by  Paul.
    #3647

    chiara0000
    Participant

    Hi Paul,

    many thanks for your answer!
    I used https://freetools.seobility.net/en/seocheck, which says that my website has a speed of 1.2s, against the suggested speed of maximum 0.4s…
    Also the page speed insights of google give it 68/100.

    I already use Autoptimize.

    What do you mean by upgrading my hosting? I currently use Site Ground.
    If you have other suggestions I would greatly appreciate it.

    Many thanks!

    Chiara

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.